Can the EdAlive Server work with an NT4 server?

All indications are that the EdAlive Server can not work with an NT4 server. Please note that NT4 is no longer supported by Microsoft.